apache httpd 解析漏洞

发布时间:2020-07-01 10:48:55 作者:小武w
来源:网络 阅读:614

漏洞背景:
apache通过mod_php来运行脚本,其2.4.0-2.4.29中存在apache换行解析漏洞,在解析php时xxx.php\x0A将被按照PHP后缀进行解析,导致绕过一些服务器的安全策略。
该漏洞属于用户配置不当产生的漏洞,与具体中间件版本无关。与其说这是漏洞,不如说是apache的特性,就是我们平常所说的从右向左解析是一样的。当apache遇到无法识别解析的文件后缀时,会向前解析,如xxx.php.123.456,在mime.types文件中如果不存在.123/.456这两种后缀,那么apache会将该文件解析为php。同样也可以在httpd.conf文件中更改参数或是直接配置.htaccess。
apache httpd 解析漏洞
直接上传个php一句话***后缀名为1.php.jgp,然后用蚁剑连接,就可以了。
apache httpd 解析漏洞apache httpd 解析漏洞
apache httpd 解析漏洞
这就连接上了
apache httpd 解析漏洞

相关推荐:如何配置Apache实现防盗链、隐藏版本信息

免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:is@yisu.com进行举报,并提供相关证据,一经查实,将立刻删除涉嫌侵权内容。

apache httpd 解析漏洞 he 解析漏洞

上一篇:php析构函数的用法

下一篇:JavaScript实现回到顶部功能的方法

相关阅读